• Facebook

    500 K / likes

  • Twitter

    1 M / followers

Some Canon T6 DSLRs May Have a Sensor Issue

12 Comments

canont6linesensor

Every once in a while my gear rental company notices something, because of the large quantities of cameras and lenses we buy, that we think people should be aware of. This particular issue won’t affect our renters; we’ve sent the affected cameras back. It may not affect very many people at all, since this is from a relatively small sample size. But I still think it worth mentioning.

The bottom line is that 4 of the Canon T6s and 2 of the T6i cameras we received had to be sent back because of a defect in the sensor stack (the layers of filter glass over the sensor). This is out about 10 copies of each; the others were absolutely perfect.

The affected cameras all had a dramatic pattern that at first we thought was oil or dust on top of the sensor glass.

t6ssensor-1024x864

Our techs first thought the dots were on top of the sensor, but they didn’t clean off. Closer examination with a 10X microscope shows they are inside, within the stack and under the top layer of glass. I would assume it’s a defect in the adhesives used to put the layers of glass together, but I don’t know for certain. One person has suggested there may have been dust on the glass when the adhesive was applied, which seems logical, but again, I have no real knowledge of how it happens.

The affected cameras all looked exactly the same, so I won’t bore you with more images. It’s quite easy to see, even without a sensor loupe, so don’t make yourself crazy trying to find it on your camera; if it’s there, you’ll notice it.

Actually, it’s easier to see without a sensor loupe. Angled light seems to show it up very clearly, lights shining directly down on the sensor not quite as much. The other cameras had no signs of this at all, so it was either a ‘yes’ or ‘no’ situation. We didn’t see any cameras with just a few dots.

We took a number of images to see how much they would show up on an actual photograph. In wider aperture shots, as you’d expect, they don’t show up at all. At about f/11 to f/16, taking pictures of sky, clouds, or a well-lit white wall, they do become apparent, but they aren’t as bad as I would have expected.

They’re also have a very different appearance than dust on the sensor does. These have have a ringed, or target appearance rather than the dark blob that sensor dust has. Below is a 100% crop from the corner of the camera with the sensor pictured above. Remember, this is an f/16 image of a clear sky. In a regular photograph at wider apertures I doubt you’d notice it.

f/16 sky image from an affected camera
f/16 sky image from an affected camera

Here’s another image that is contrast boosted quite a bit, showing the bulls eye pattern a bit more clearly.

Contrast enhanced f/16 photo showing the pattern is very different than dust on the sensor.
Contrast enhanced f/16 photo showing the pattern is very different than dust on the sensor.

All of the cameras we received had early SNs, and there is not going to be a direct serial number correlation with the problem. For example, we had 7 cameras in the SN 0220310007X range. Cameras with the last digit of 2 and 4 were affected, but 3 and 6 were not. That’s not surprising, really, since sensors would be manufactured somewhere else and then placed into the camera during assembly.

I’ve talked to people at Canon about this issue and they are aggressively looking into it. It will take some time for them to figure out what the issue is, where it occurred, and what cameras might be affected. They’re actively looking into the situation. They are NOT telling me, as some manufactures do, that there is no problem.

My guess, and it’s just a guess, is that a bad batch of sensors were made, quality control missed this, and they got put into cameras. How big is a batch? I have no clue. Maybe it’s just a few hundred and we happened to get a lot (all of the cameras we’ve received have been pretty close in serial number). Maybe it’s thousands. Time will tell and I’m comfortable the problem is being addressed.

Oh, and for those of you who want to bash Canon Quality Control over this, well it’s appropriate, I won’t stand in your way. But I can’t because when I looked at these cameras myself the first time, I missed two of the ones with bad sensors. Like I mentioned earlier, direct light through a sensor loupe didn’t reveal it nearly as well as an angled spot light did. (Now you know how we figured that out.) It’s possible the inspection of the sensors after assembly is done using a direct light, or some other automated equipment that isn’t capable of seeing this.

So I’m not throwing any stones out of my glass house. And having dealt with many manufacturers concerning many issues over the years, I’m just pleased that this issue is being taken seriously and investigated immediately. That’s not always the case.

In the meantime, check your new T6 when you get it, return it if you need to.


About the author: Roger Cicala is the founder of LensRentals. This article originally appeared here.

12 Comments